首页 » 互联网资讯 » 正文

如何避免安装php时,自动安装apache2?

install php7.3
总会自动安装apache2,还会安装这个服务,debian和ubuntu还会出现红色出来表示服务安装不成功, centos稍微表现好点没有这个红色apache2 service
php都进化这么多代了,为啥不把apache剥离开来,用扩展安装?

我只用nginx,不希望安装apache apache2
尽管不耽误使用,洁癖没法呀;毕竟也占用资源不是

自己编译安装,就不用了,太折腾时间



吉林网友 木飞鱼suzhou 评论:
ubu不是有个–非缺省参数吗,我安装软件都用这个,只要不是硬性依赖包都不会安装


河北网友 Hovini 评论:
no install recommend


甘肃网友 还便 评论:
安php-fpm就不会安apache了


甘肃网友 Y先生5227 评论:
Php7.3_fpm


江苏网友 天津劲擎车队底火 评论:

ubu不是有个–非缺省参数吗,我安装软件都用这个,只要不是硬性依赖包都不会安装 …

ubuntu我是用ppa : ondrej进行安装
这样有点通用性,免得u18 u16的参数又不一样,写一大堆if语句

你说的方法,给个链接学习下,或者给个例子


辽宁网友 choison 评论:

no install recommend

我只晓得2种:install + 编译

编译太费时间,我选择放弃。

你还有啥高招?


贵州网友 我要绑架你 评论:

安php-fpm就不会安apache了

我不仅仅安装php-fpm呢,有30多个扩展要安装。

不安装能php行吗?php -version都查不到,哈哈


四川网友 AriesGF 评论:
虽然我一直是Apache去干php,但是
这样也会依赖安装的么?


贵州网友 shenhua248 评论:
我自己写脚本,不晓得你这个是啥

发表评论