首页 » 互联网资讯 » 正文

CentOS 5.8 无法使用yum安装screen,求解决方法

新购置的饭桶的VPS,1GB内存,安装的是CentOS5.8 32位系统,出现无法安装Lnmp的情况,经过更换系统(更换为5.5,问题和5.8一样,同样无法安装Lnmp,报错都一样;更换为6.0,无法使用SSH远程登录;更换为6.2,系统无法启动;真是晕死~~~),最后还是回到CentOS5.8。先尝试安装screen命令,出现如下错误:——————————————————————————————————————————-
#  yum install screen
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.sonic.net
* extras: mirrors.bluehost.com
* updates: mirrors.usc.edu
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package screen.x86_64 0:4.0.3-4.el5 set to be updated
–> Processing Dependency: libc.so.6(GLIBC_2.2.5)(64bit) for package: screen
–> Processing Dependency: libc.so.6(GLIBC_2.3.4)(64bit) for package: screen
–> Processing Dependency: libc.so.6(GLIBC_2.4)(64bit) for package: screen
–> Processing Dependency: libpam.so.0(LIBPAM_1.0)(64bit) for package: screen
–> Processing Dependency: libcrypt.so.1(GLIBC_2.2.5)(64bit) for package: screen
–> Processing Dependency: libc.so.6()(64bit) for package: screen
–> Processing Dependency: libpam.so.0()(64bit) for package: screen
–> Processing Dependency: libutil.so.1()(64bit) for package: screen
–> Processing Dependency: libutempter.so.0()(64bit) for package: screen
–> Processing Dependency: libcrypt.so.1()(64bit) for package: screen
–> Processing Dependency: libncurses.so.5()(64bit) for package: screen
–> Running transaction check
—> Package glibc.i686 0:2.5-81.el5_8.7 set to be updated
–> Processing Dependency: glibc-common = 2.5-81.el5_8.7 for package: glibc
—> Package glibc.x86_64 0:2.5-81.el5_8.7 set to be updated
—> Package libutempter.x86_64 0:1.1.4-4.el5 set to be updated
—> Package ncurses.x86_64 0:5.5-24.20060715 set to be updated
—> Package pam.x86_64 0:0.99.6.2-6.el5_5.2 set to be updated
–> Processing Dependency: libselinux.so.1()(64bit) for package: pam
–> Processing Dependency: libaudit.so.0()(64bit) for package: pam
–> Processing Dependency: libcrack.so.2()(64bit) for package: pam
–> Running transaction check
—> Package audit-libs.x86_64 0:1.8-2.el5 set to be updated
—> Package cracklib.x86_64 0:2.8.9-3.3 set to be updated
—> Package glibc-common.x86_64 0:2.5-81.el5_8.7 set to be updated
—> Package libselinux.x86_64 0:1.33.4-5.7.el5 set to be updated
–> Processing Dependency: libsepol.so.1()(64bit) for package: libselinux
–> Running transaction check
—> Package libsepol.x86_64 0:1.15.2-3.el5 set to be updated
–> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================
Package                  Arch               Version                         Repository           Size
=======================================================================================================
Installing:
screen                   x86_64             4.0.3-4.el5                     base                571 k
Installing for dependencies:
audit-libs               x86_64             1.8-2.el5                       base                 80 k
cracklib                 x86_64             2.8.9-3.3                       base                 63 k
glibc                    x86_64             2.5-81.el5_8.7                  updates             4.8 M
glibc-common             x86_64             2.5-81.el5_8.7                  updates              16 M
libselinux               x86_64             1.33.4-5.7.el5                  base                 78 k
libsepol                 x86_64             1.15.2-3.el5                    base                131 k
libutempter              x86_64             1.1.4-4.el5                     base                 22 k
ncurses                  x86_64             5.5-24.20060715                 base                1.2 M
pam                      x86_64             0.99.6.2-6.el5_5.2              base                978 k
Updating for dependencies:
glibc                    i686               2.5-81.el5_8.7                  updates             5.4 M

Transaction Summary
=======================================================================================================
Install      10 Package(s)
Upgrade       1 Package(s)

Total size: 30 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
ld-linux.so.2 is needed by (installed) libstdc++-4.1.2-52.el5.i386
ld-linux.so.2 is needed by (installed) libselinux-1.33.4-5.7.el5.i386
ld-linux.so.2 is needed by (installed) e2fsprogs-libs-1.39-33.el5.i386
ld-linux.so.2(GLIBC_2.3) is needed by (installed) libstdc++-4.1.2-52.el5.i386
…………
…………
…………
libutil.so.1 is needed by (installed) openssh-server-4.3p2-82.el5.i386
libutil.so.1(GLIBC_2.0) is needed by (installed) pam-0.99.6.2-6.el5_5.2.i386
libutil.so.1(GLIBC_2.0) is needed by (installed) util-linux-2.13-0.59.el5.i386
libutil.so.1(GLIBC_2.0) is needed by (installed) python-libs-2.4.3-46.el5.i386
libutil.so.1(GLIBC_2.0) is needed by (installed) openssh-server-4.3p2-82.el5.i386
Complete!
(1, [u’Please report this error in http://bugs.centos.org/yum5bug’])

# screen -S lnmp
-bash: screen: command not found
—————————————————————————————————————

看上面红色的部分,显示的应该是错误,难道是这个系统的yum有问题吗?还是安装源的问题,求高人指点,谢谢!


系统问题

日本IJJ VPS

发表评论